首页 > 其他 > 详细

FZU Problem 2104 Floor problem (数学啊 )

时间:2014-12-04 23:16:32      阅读:337      评论:0      收藏:0      [点我收藏+]

题目链接:http://acm.fzu.edu.cn/problem.php?pid=2104


Problem Description

In this problem, we have f(n,x)=Floor[n/x]. Here Floor[x] is the biggest integer such that no larger than x. For example, Floor[1.1]=Floor[1.9]=1, Floor[2.0]=2.

You are given 3 positive integers n, L and R. Print the result of f(n,L)+f(n,L+1)+...+f(n,R), please.

bubuko.com,布布扣 Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 3 integers n, L and R (1≤n, L, R≤10,000, L≤R).

bubuko.com,布布扣 Output

For each test case, print the result of f(n,L)+f(n,L+1)+...+f(n,R) in a single line.

bubuko.com,布布扣 Sample Input

31 2 3100 2 100100 3 100

bubuko.com,布布扣 Sample Output

0382332

bubuko.com,布布扣 Source

“高教社杯”第三届福建省大学生程序设计竞赛


代码如下:

#include <cstdio>
#include <cmath>
int main()
{
    int t;
    int n, l, r;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&l,&r);
        double sum = 0;
        for(int i = l; i <= r; i++)
        {
            sum+=floor(n*1.0/i);
        }
        printf("%.0lf\n",sum);
    }
    return 0;
}



FZU Problem 2104 Floor problem (数学啊 )

原文:http://blog.csdn.net/u012860063/article/details/41731765

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!