首页 > 其他 > 详细

武汉科技大学ACM :1008: A+B for Input-Output Practice (VIII)

时间:2014-12-05 20:56:34      阅读:323      评论:0      收藏:0      [点我收藏+]

Problem Description

Your task is to calculate the sum of some integers.

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 

Output

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output

10

15

6


#include <iostream>  
using namespace std;  
  
int main()  
{  
    int N;  
    cin >> N;  
    while (N--)  
    {  
        int M,sum = 0;  
        cin >> M;  
        while (M--)  
        {  
            int i;  
            cin >> i;  
            sum += i;  
        }  
        cout << sum << endl;  
        if (N != 0)cout << endl;//没有此行运行时会出现错误:Presentation Error  
    }  
  
return 0;  
}  

 

武汉科技大学ACM :1008: A+B for Input-Output Practice (VIII)

原文:http://www.cnblogs.com/liuwt365/p/4147462.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!