首页 > 其他 > 详细

FZU Problem 2111 Min Number (数学啊 )

时间:2014-12-05 21:22:34      阅读:366      评论:0      收藏:0      [点我收藏+]

题目链接:http://acm.fzu.edu.cn/problem.php?pid=2111


Problem Description

Now you are given one non-negative integer n in 10-base notation, it will only contain digits (‘0‘-‘9‘). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

bubuko.com,布布扣 Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

bubuko.com,布布扣 Output

For each test case, output the minimum number we can get after no more than M operations.

bubuko.com,布布扣 Sample Input

3
9012 0
9012 1
9012 2

bubuko.com,布布扣 Sample Output

9012
1092
1029

bubuko.com,布布扣 Source

“高教社杯”第三届福建省大学生程序设计竞赛

题意:

给出一个数字,求经过n次交换后最小的数字!

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int main()
{
    int t;
    int n;
    char s[117];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s%d",s,&n);
        int len = strlen(s);
        for(int i = 0; i < n; i++)
        {
            int tt = s[i]-'0';
            int pos = 0, minn = tt;
            for(int j = i+1; j < len; j++)
            {
                if(i == 0 && s[j] == '0')//首位
                    continue;
                if(s[j]-'0' < minn)
                {
                    minn = s[j]-'0';
                    pos = j;
                }
            }
            if(pos != 0)
                swap(s[i],s[pos]);
            else//无效操作
                n++;
            if(n >= len)
                n = len-1;
        }
        printf("%s\n",s);
    }
    return 0;
}


FZU Problem 2111 Min Number (数学啊 )

原文:http://blog.csdn.net/u012860063/article/details/41752751

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!