首页 > 其他 > 详细

poj 2406 Power Strings

时间:2014-12-05 22:47:14      阅读:431      评论:0      收藏:0      [点我收藏+]
Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 33636   Accepted: 13973

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4

3

题目大意:给出一个字符串,求这个串是有几个子串构成的 思路:用KMP算法中的next数组,这个字符串的next数组里边,字符串的总长度减去最后一个字符所对应的next值就是子串的长度 具体为什么,应该是next数组的值是根据这个字符串本身,用一定规则得出的,这个真的好巧妙的说,kmp算法,好好看看。 2014,12,5

#include<stdio.h>
#include<string.h>
char x[1100000];
int next[1100000];
void getnext(char s[]){
	int len1,i,j;
	len1=strlen(s);
	i=0;j=-1;
	next[i]=j;
	while(i<len1){
		if(j==-1||s[i]==s[j]){
			++i;++j;
			next[i]=j;
		}
		else j=next[j];
	}
}
int main(){
	int t,len;
	while(scanf("%s",x)){
		getnext(x);
		if(x[0]=='.') break;
		else {
			len=strlen(x);
			t=len-next[len];
			if(len%t==0)
				printf("%d\n",len/t);
			else printf("1\n");	
		}
	}
	return 0;
}


poj 2406 Power Strings

原文:http://blog.csdn.net/ling_du/article/details/41758131

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!