A Bug‘s Life
Time Limit: 10000MS |
|
Memory Limit: 65536K |
Total Submissions: 29030 |
|
Accepted: 9455 |
Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy
to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each
interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs‘ sexual
behavior, or "Suspicious bugs found!" if Professor Hopper‘s assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output
Scenario #1:
Suspicious bugs found!
Scenario #2:
No suspicious bugs found!
Hint
Huge input,scanf is recommended.
题意:找是不是同性恋的两条虫子。
参考:http://www.cnblogs.com/dongsheng/archive/2012/08/08/2627917.html
代码:
#include <cstdio>
#include <cstring>
const int M = 2050;
int fat[M], ral[M];
int f(int x){
if(fat[x] != x){
int root = fat[x];
fat[x] = f(fat[x]);
ral[x] = (ral[x]+ral[root])%2;
}
return fat[x];
}
int main(){
int t, v = 1, n, m;
scanf("%d", &t);
while(t --){
scanf("%d%d", &n, &m);
int i, a, b;
for(i = 1; i < M; i++) fat[i] = i;
memset(ral, 0, sizeof(ral));
int flag = 0;
while(m --){
scanf("%d%d", &a, &b);
if(flag) continue;
else{
int x = f(a); int y = f(b);
if(x == y){
if(ral[a] == ral[b]) flag = 1;
}
else{
fat[x] = y;
ral[x] = (ral[a]+ral[b]+1)%2;
}
}
}
printf("Scenario #%d:\n", v++);
if(flag)
printf("Suspicious bugs found!\n");
else
printf("No suspicious bugs found!\n");
if(t)
printf("\n");
}
return 0;
}
poj 2492 A Bug's Life 【并查集拓展】
原文:http://blog.csdn.net/shengweisong/article/details/41746857