首页 > 其他 > 详细

UVA 10106-Product(大数乘法)

时间:2014-12-08 09:19:57      阅读:249      评论:0      收藏:0      [点我收藏+]

Product
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

bubuko.com,布布扣


 Product 

The Problem

The problem is to multiply two integers X, Y. (0<=X,Y<10250)

The Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

The Output

For each input pair of lines the output line should consist one integer the product.

Sample Input

12
12
2
222222222222222222222222

Sample Output

144
444444444444444444444444

注意当为0的情况,一开始忽略了这种情况。当任一个为0的时候别忘了输出0


#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char str1[1010],str2[1010];
char a[1010],b[1010],sum[1010];
int main()
{
    int len1,len2;
    int i,j;
    while (~scanf("%s",str1))
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(sum,0,sizeof(sum));
        len1= strlen(str1);
        for (i=len1-1;i>=0;i--)
            a[len1-i-1]=str1[i]-'0';
        scanf("%s",str2);
        len2=strlen(str2);
        for (i=len2-1;i>=0;i--)
            b[len2-i-1]=str2[i]-'0';
        for (i=0;i<len1;i++)
        {
            for(j=0;j<len2;j++)
                sum[i+j]+=a[i]*b[j];
            for (j=0;j<1010;j++)
                if (sum[j]>=10)
                {
                    sum[j+1]+=sum[j]/10;
                    sum[j]%=10;
                }
        }
        int flag=0;
        for(i=1010;i>=0;i--)
        {
            if(flag||sum[i])
            {
                flag=1;
                printf("%d",sum[i]);
            }
        }
        if(!flag)
            printf("0");
        printf("\n");
    }
    return 0;
}


UVA 10106-Product(大数乘法)

原文:http://blog.csdn.net/u013486414/article/details/41794631

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!