首页 > 其他 > 详细

POJ1423 Big Number 【求N的阶乘的位数】

时间:2014-12-08 12:24:57      阅读:276      评论:0      收藏:0      [点我收藏+]

Big Number
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 26151   Accepted: 8349

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= m <= 10^7 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20

Sample Output

7
19

Source

#include <stdio.h>
#include <math.h>

const double PI = acos(-1.0);
const double E = exp(1.0);

int main() {
	int t, n;
	scanf("%d", &t);
	while(t--) {
		scanf("%d", &n);
		printf("%d\n", (int)(log10(2*PI*n)/2+n*log10(n/E))+1);
	}
    return 0;
}



POJ1423 Big Number 【求N的阶乘的位数】

原文:http://blog.csdn.net/chang_mu/article/details/41575099

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!