首页 > 其他 > 详细

[哈希]PAT1039 Course List for Student

时间:2014-02-28 15:40:23      阅读:433      评论:0      收藏:0      [点我收藏+]

1039. Course List for Student (25)

时间限制
200 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student‘s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题意:关于学生选课的问题,给出了每门课的序号和选课的学生名字,然后查询学生的选课情况。

思路:这道题数据量较大卡时也比较严格。用string和cin,cout会超时。还有一点就是将学生的姓名映射到一个整数,这样存取就方便了很多。

#include<iostream>
#include<algorithm>
#include<cstring>
#include<vector>
#include<cstdio>

using namespace std;


int stringtoint(char *str)
{
    return 6760 * (str[0]-65) + 260 * (str[1]-65) + 10*(str[2]-65) + (str[3] - 48);
}

vector<int> vec[180000];

bool cmp(int x,int y)
{
    return x<y;
}

int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    int i,j,k,r,t;
    char str[5];
    for(i=0;i<m;i++)
    {
        scanf("%d%d",&r,&t);
        for(j=0;j<t;j++)
        {
            scanf("%s",str);
            k=stringtoint(str);
            vec[k].push_back(r);
        }
    }

    for(i=0;i<n;i++)
    {
        scanf("%s",str);
        k=stringtoint(str);
        sort(vec[k].begin(),vec[k].end(),cmp);
        printf("%s %d",str,vec[k].size());
        for(j=0;j<vec[k].size();j++)
            printf(" %d",vec[k][j]);
        printf("\n");
    }
    return 0;
}



[哈希]PAT1039 Course List for Student,布布扣,bubuko.com

[哈希]PAT1039 Course List for Student

原文:http://blog.csdn.net/zju_ziqin/article/details/20069133

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!