首页 > 其他 > 详细

HDOJ 2802 F(N)

时间:2014-12-14 13:16:37      阅读:324      评论:0      收藏:0      [点我收藏+]


循环节4018

F(N)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3542    Accepted Submission(s): 1219


Problem Description
bubuko.com,布布扣
Giving the N, can you tell me the answer of F(N)?
 

Input
Each test case contains a single integer N(1<=N<=10^9). The input is terminated by a set starting with N = 0. This set should not be processed.
 

Output
For each test case, output on a line the value of the F(N)%2009.
 

Sample Input
1 2 3 0
 

Sample Output
1 7 20
 

Source
 



/* ***********************************************
Author        :CKboss
Created Time  :2014年12月14日 星期日 12时29分33秒
File Name     :HDOJ2802.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <cmath>

using namespace std;

const int mod=2009;

int f[5000];

int Get(int x)
{
	int part1=((x*x)%mod*x)%mod;
	int y=x-1;
	int part2=((y*y)%mod*y)%mod;
	return ((f[x-2]+part1)%mod+mod-part2)%mod;
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

	int n;
	f[1]=1; f[2]=7;
	for(int i=3;i<=4018;i++) f[i]=Get(i);

	while(scanf("%d",&n)!=EOF&&n)
	{
		n=n%4018;
		if(n==0) puts("0");
		else printf("%d\n",f[n]);
	}

    return 0;
}



HDOJ 2802 F(N)

原文:http://blog.csdn.net/ck_boss/article/details/41924343

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!