首页 > 其他 > 详细

PAT 解题报告 1050. String Subtraction (20)

时间:2014-03-01 11:00:18      阅读:291      评论:0      收藏:0      [点我收藏+]

1050. String Subtraction (20)

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

题意

给定两个字符串,S1 和 S2,要求将 S2 中的字符从 S1 串中剔除。

分析

用 Hash 的方式标记需要剔除的字符。

 

bubuko.com,布布扣
#include <iostream>
#include <cstdio>
#include <string>

using namespace std;

int main()
{
    int hs[256] ={0};
    char cs[10001];
    gets(cs);
    string st = cs;
    //getline(cin, st);
    while (1) {
        char c = getchar();
        if (c == \n) break;
        hs[c] = 1;
    }

    for (int i=0; i<st.size(); i++) {
        if (hs[st[i]] == 0)
            printf("%c", st[i]);
    }

    return 0;
}
bubuko.com,布布扣

PAT 解题报告 1050. String Subtraction (20),布布扣,bubuko.com

PAT 解题报告 1050. String Subtraction (20)

原文:http://www.cnblogs.com/549294286/p/3574247.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!