首页 > 其他 > 详细

HDU 1159 Common Subsequence (备忘录DP)

时间:2014-12-19 13:04:52      阅读:157      评论:0      收藏:0      [点我收藏+]

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24493    Accepted Submission(s): 10826


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

Sample Output
4 2 0
 

#include<stdio.h>
#include<string.h>
int c[1001][1001];
char a[1001];
char b[1001];
int max(int a,int b){
    if(a>b)return a;
    else
        return b;
}
int dp(int i,int j){
	if(c[i][j]>-1)
		return c[i][j];
	if(i==0||j==0)
		c[i][j]=0;
	else{
		if(a[i-1]==b[j-1])
			c[i][j]=dp(i-1,j-1)+1;
		else
			c[i][j]=max(dp(i,j-1),dp(i-1,j));

	}
        return c[i][j];
}
int memorized_LCS_LENGTH(){
	int m=strlen(a);
	int n=strlen(b);
	for(int i=1;i<=m;i++)
		for(int j=1;j<=n;j++)
		c[i][j]=-1;
    return dp(m,n);
}
int main(int argc, char *argv[])
{
    while(~scanf("%s%s",a,b))
    {
        printf("%d\n",memorized_LCS_LENGTH());
    }
    return 0;
}



HDU 1159 Common Subsequence (备忘录DP)

原文:http://blog.csdn.net/wdkirchhoff/article/details/41990341

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!