首页 > 其他 > 详细

poj 1656 Counting Black

时间:2014-12-30 17:15:20      阅读:204      评论:0      收藏:0      [点我收藏+]

Counting Black
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 10360   Accepted: 6691

Description

There is a board with 100 * 100 grids as shown below. The left-top gird is denoted as (1, 1) and the right-bottom grid is (100, 100). 
技术分享

We may apply three commands to the board: 
1.	WHITE  x, y, L     // Paint a white square on the board, 

                           // the square is defined by left-top grid (x, y)

                           // and right-bottom grid (x+L-1, y+L-1)



2.	BLACK  x, y, L     // Paint a black square on the board, 

                           // the square is defined by left-top grid (x, y)

                           // and right-bottom grid (x+L-1, y+L-1)



3.	TEST     x, y, L    // Ask for the number of black grids 

                            // in the square (x, y)- (x+L-1, y+L-1) 

In the beginning, all the grids on the board are white. We apply a series of commands to the board. Your task is to write a program to give the numbers of black grids within a required region when a TEST command is applied. 

Input

The first line of the input is an integer t (1 <= t <= 100), representing the number of commands. In each of the following lines, there is a command. Assume all the commands are legal which means that they won‘t try to paint/test the grids outside the board.

Output

For each TEST command, print a line with the number of black grids in the required region.

Sample Input

5
BLACK 1 1 2
BLACK 2 2 2
TEST 1 1 3
WHITE 2 1 1
TEST 1 1 3

Sample Output

7
6

题意:

对于一个100*100棋盘,进行下列三种操作

BLACK x y l  将(x,y)为左上角,边长为l的正方形涂黑

WHITE x y l  将(x,y)为左上角,边长为l的正方形涂白

TEST x y l 问(x,y)为左上角,边长为l的正方形有多少个黑色格子

参考代码:

#include <iostream>
#include <string.h>
using namespace std;
#define MAX 100
int main(){
	int map[MAX][MAX];
	int t,x,y,l;
	char s[20];
	while (cin>>t){
		memset(map,0,sizeof(map));
		while (t--){
			cin>>s>>x>>y>>l;
			if (strcmp(s,"BLACK")==0){
				for (int i=x;i<x+l;i++){
					for (int j=y;j<y+l;j++){
						map[i][j]=1;
					}
				}
			}
			if (strcmp(s,"WHITE")==0){
				for (int i=x;i<x+l;i++){
					for (int j=y;j<y+l;j++){
						map[i][j]=2;
					}
				}
			}
			if (strcmp(s,"TEST")==0){
				int count=0;
				for (int i=x;i<x+l;i++){
					for (int j=y;j<y+l;j++){
						if (map[i][j]==1)
							count++;
					}
				}
				cout<<count<<endl;
			}
		}
	}
	return 0;
}

每天水一发~



poj 1656 Counting Black

原文:http://blog.csdn.net/codeforcer/article/details/42266659

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!