首页 > 其他 > 详细

ZOJ3758:Singles' Day(快速素数判定法)

时间:2014-03-04 16:35:51      阅读:513      评论:0      收藏:0      [点我收藏+]

Singles‘ Day(or One‘s Day), an unofficial holiday in China, is a pop culture entertaining holiday on November 11 for young Chinese to celebrate their bachelor life. With the meaning of single or bachelor of number ‘1‘ and the huge population of young single man. This festival is very popular among young Chinese people. And many Young bachelors organize parties and Karaoke to meet new friends or to try their fortunes that day.

On Singles‘ Day, a supermarket has a promotional activity. Each customer will get a ticket on which there are two integers b and N, representing an integer M that only contains N digits 1 using b as the radix. And if the number M is a prime number, you will get a gift from the supermarket.

Since there are so many customers, the supermarket manager needs your help.

Input

There are multiple test cases. Each line has two integers b and N indicating the integer M, which might be very large. (2 <= b <= 16, 1 <= N <= 16)

Output

If the customer can get a gift, output "YES", otherwise "NO".

Sample Input

3 3
2 4
2 1
10 2

Sample Output

YES
NO
NO
YES

Hint

For the first sample, b=3, N=3, so M=(111)3, which is 13 in decimal. And since 13 is a prime number, the customer can get a gift, you should output "YES" on a line.

 

题意很简单,就是求长度为n的b进制数在每一位都是1的情况下,是不是素数,这里我用了快速素数判定法

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;

long long sum;
long long ppow(int n,int k)
{
    long long ans = 1;
    int i;
    if(n == 0)
        return 1;
    for(i = 1; i<=n; i++)
        ans = ans*k;
    return ans;
}

bool prime (long long num)
{
    if (num == 2 || num == 3 || num == 5)
        return true;
    if (num % 2 == 0 || num % 3 == 0 || num % 5 == 0 || num == 1)
        return false;

    long long c = 7;
    int maxc = (int)(sqrt (num));
    while (c <= maxc)
    {
        if (num % c == 0)
            return false;
        c += 4;
        if (num % c == 0)
            return false;
        c += 2;
        if (num % c == 0)
            return false;
        c += 4;
        if (num % c == 0)
            return false;
        c += 2;
        if (num % c == 0)
            return false;
        c += 4;
        if (num % c == 0)
            return false;
        c += 6;
        if (num % c == 0)
            return false;
        c += 2;
        if (num % c == 0)
            return false;
        c += 6;
    }
    return true;
}


int main()
{
    int i,j,n,b,a;
    while(~scanf("%d%d",&b,&n))
    {
        sum = 0;
        for(i = 0; i<n; i++)
            sum+=ppow(i,b);
        if(sum%2==0 || sum == 1)
            printf("NO\n");
        else
        {
           bool flag = prime(sum);
            if(!flag)
                printf("NO\n");
            else
                printf("YES\n");
        }
    }

    return 0;
}


 

 

ZOJ3758:Singles' Day(快速素数判定法),布布扣,bubuko.com

ZOJ3758:Singles' Day(快速素数判定法)

原文:http://blog.csdn.net/libin56842/article/details/20401871

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!