首页 > 其他 > 详细

(欧拉函数) SGU 102

时间:2015-01-20 13:28:56      阅读:241      评论:0      收藏:0      [点我收藏+]
A - Coprimes
Time Limit:250MS     Memory Limit:4096KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

 

For given integer N (1<=N<=104) find amount of positive numbers not greater than N that coprime with N. Let us call two positive integers (say, A and B, for example) coprime if (and only if) their greatest common divisor is 1. (i.e. A and B are coprime iff gcd(A,B) = 1).

 

Input

Input file contains integer N.

 

Output

Write answer in output file.

 

Sample Input

9

Sample Output

6
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int n;
int main()
{
      scanf("%d",&n);
      int m=n;
      for(int p=2;n!=1;p++)
      {
            if(n%p==0)
                  m=m-m/p;
            while(n%p==0)
                  n=n/p;
      }
      printf("%d\n",m);
      return 0;
}

  

(欧拉函数) SGU 102

原文:http://www.cnblogs.com/a972290869/p/4235751.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!