首页 > 其他 > 详细

CDZSC_2015寒假新人(1)——基础 H

时间:2015-01-23 13:14:24      阅读:182      评论:0      收藏:0      [点我收藏+]

Description

Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?       
Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.       
Note: if year Y is a leap year, then the 1st leap year is year Y.       
              

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.        Each test case contains two positive integers Y and N(1<=N<=10000).       
              

Output

For each test case, you should output the Nth leap year from year Y.       
              

Sample Input

3
2005 25
1855 12
2004 10000
              

Sample Output

2108
1904
43236

Hint

We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.

 

技术分享
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int main()
{
#ifdef CDZSC_OFFLINE
    freopen("in.txt","r",stdin);
#endif
    int year,t,n,sum;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        scanf("%d%d",&year,&n);
        while(sum<n)
        {
            if((year%4==0&&year%100!=0)||(year%400==0))
            {
                sum++;
            }
            year++;
        }
        printf("%d\n",year-1);
    }
    return 0;
}
View Code

 

CDZSC_2015寒假新人(1)——基础 H

原文:http://www.cnblogs.com/Wing0624/p/4243836.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!