Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers
in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
105
10296
思路:写一个两两求最小公倍数的函数(用long long)然后循环处理
ps vc环境的__int64貌似在处理较小的数时容易出现错误
#include<stdio.h>
#include<iostream>
using namespace std;
long long lcd(long long n,long long m)
{
long long r;
//scanf("%d%d",&n,&m);
if(n<m)swap(n,m);
long long p=n*m;
while(m!=0)
{
r=n%m;
n=m;
m=r;
}
return p/n;
}
int main()
{
long long num[100];
int n1,n2,o;
scanf("%d",&n1);
while(n1--)
{
scanf("%d",&n2);
for(int o=0;o<n2;o++)
{
scanf("%lld",&num[o]);
}
for(o=1;o<n2;o++)
{
num[o]=lcd(num[o],num[o-1]);
}
printf("%lld\n",num[o-1]);
}
}
杭电acm:最小公倍数(附源码)
原文:http://blog.csdn.net/qq754406613/article/details/43156805