首页 > 其他 > 详细

SDJZU_新生_递推动规_HDU 1159 Common Subsequence

时间:2015-01-29 10:25:13      阅读:255      评论:0      收藏:0      [点我收藏+]
Common Subsequence
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

Input

输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
 

Output

对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
 

Sample Input

abcfbc abfcab programming contest abcd mnp
 

Sample Output

4 2 0
         
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
char a[2010];
char b[2010];
int dp[2010][2010];
int main(){
while(scanf("%s%s",&a,&b)!=EOF){
        int a1=strlen(a);
        int b1=strlen(b);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<a1+1;i++)
        {
            for(int j=1;j<b1+1;j++)
            {
                if(a[i-1]==b[j-1])
                {
                    dp[i][j]=dp[i-1][j-1]+1;
                }
                else
                {
                        if(dp[i-1][j]>dp[i][j-1])
                        {
                            dp[i][j]=dp[i-1][j];
                        }
                        else
                        {
                            dp[i][j]=dp[i][j-1];
                        }
                }
            }
        }
        printf("%d\n",dp[a1][b1]);
}
return 0;
}


SDJZU_新生_递推动规_HDU 1159 Common Subsequence

原文:http://blog.csdn.net/floating_life/article/details/43267255

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!