首页 > 编程语言 > 详细

(hdu step 1.3.8)Who's in the Middle(排序)

时间:2015-01-29 22:38:14      阅读:450      评论:0      收藏:0      [点我收藏+]

题目:

Who‘s in the Middle

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2938 Accepted Submission(s): 1109
 
Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median‘ cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 
Input
* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 
Output
* Line 1: A single integer that is the median milk output.
 
Sample Input
5
2
4
1
3
5
 
Sample Output
3

Hint
INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.
 
 
Source
USACO 2004 November
 
Recommend
mcqsmall
 



题目分析:

              排序,然后输出中位数



代码如下:

/*
 * i.cpp
 *
 *  Created on: 2015年1月29日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>
#include <algorithm>


using namespace std;

const int maxn = 10005;
int a[maxn];

int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		int i;
		for(i = 0 ; i < n ; ++i){
			scanf("%d",&a[i]);
		}

		sort(a,a+n);

		printf("%d\n",a[n/2]);
	}

	return 0;
}



       



(hdu step 1.3.8)Who's in the Middle(排序)

原文:http://blog.csdn.net/hjd_love_zzt/article/details/43278469

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!