Tree Recovery
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 11955 |
|
Accepted: 7505 |
Description
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:
D
/
/
B E
/ \
/ \
A C G
/
/
F
To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF
and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!
Input
The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.
Output
For each test case, recover Valentine‘s binary tree and print one line containing the tree‘s postorder traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG
BCAD CBAD
Sample Output
ACBFGED
CDAB
题意:已知前序和中序,求后序
参考代码:
//由前序和中序求后序
#include <iostream>
#include <string.h>
using namespace std;
typedef struct node{
char data;
node *left,*right;
}*tree;
char preorder[100],inorder[100];
/* 由前序、中序构造树
* i: 子树的前序序列字符串的首字符在preorder[]中的下标
* j: 子树的中序序列字符串的首字符在inorder[]中的下标
* len: 子树的字符串序列的长度
*/
void CreatTree(tree &t,int i,int j,int len){
if (len<=0)
return;
if (t==NULL){
t=new node;
t->left=t->right=NULL;
}
t->data=preorder[i];
int m=strchr(inorder,preorder[i])-inorder; //preorder[i]在inorder[]第几个字符
CreatTree(t->left,i+1,j,m-j);
CreatTree(t->right,i+(m-j)+1,m+1,len-1-(m-j));
}
/*后序遍历*/
void PostOrder(tree t){
if(t!=NULL){
PostOrder(t->left); //访问左子结点
PostOrder(t->right); //访问右子结点
cout<<(t->data); //访问根节点
}
}
int main(){
while (cin>>preorder>>inorder){
tree t=NULL;
int len=strlen(preorder);
CreatTree(t,0,0,len);
PostOrder(t);
cout<<endl;
}
return 0;
}
poj2255 Tree Recovery
原文:http://blog.csdn.net/codeforcer/article/details/43489873