首页 > 其他 > 详细

HDU 1058 Humble Numbers && NOJ 1420 丑数 (数位dp)

时间:2015-02-05 11:21:18      阅读:233      评论:0      收藏:0      [点我收藏+]

Humble Numbers

                         Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                         Total Submission(s): 18555    Accepted Submission(s): 8080


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 

Source
 
题目链接:HDU 1058   NOJ 1420

题目大意:一组数,它的素因子只包含2 3 5 7求这组数的第n个

题目分析:数位dp,离线计算出结果,dp[i]表示第i个数,从小到大往后推即可,每次dp取当前最小值,详细见程序


#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
int dp[5843] = {1};

int Min(int a, int b, int c, int d)
{
    return min(a, min(b, min(c, d)));
}

void cal()
{
    int a = 1, b = 1, c = 1, d = 1;
    dp[1] = 1;
    for(int i = 1; i <= 5843; i++)
    {
        int get = Min(2 * dp[a], 3 * dp[b], 5 * dp[c], 7 * dp[d]);
        dp[i + 1] = get;
        if(get == 2 * dp[a])
            a++;
        if(get == 3 * dp[b])
            b++;
        if(get == 5 * dp[c])
            c++;
        if(get == 7 * dp[d])
            d++;
    }
}

int main()
{
    int n;
    cal();
    while(scanf("%d", &n) != EOF && n)
    {
        if(n % 10 == 1 && n % 100 != 11)
            printf("The %dst humble number is %d.\n", n, dp[n]);
        else if(n % 10 == 2 && n % 100 != 12)
            printf("The %dnd humble number is %d.\n", n, dp[n]);
        else if(n % 10 == 3 && n % 100 != 13)
            printf("The %drd humble number is %d.\n", n, dp[n]);
        else
            printf("The %dth humble number is %d.\n", n, dp[n]);
    }
}




HDU 1058 Humble Numbers && NOJ 1420 丑数 (数位dp)

原文:http://blog.csdn.net/tc_to_top/article/details/43524399

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!