首页 > 其他 > 详细

POJ 1163 The Triangle

时间:2015-02-05 23:27:17      阅读:520      评论:0      收藏:0      [点我收藏+]

题目链接:http://poj.org/problem?id=1163


The Triangle
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 39022   Accepted: 23430

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Source

题意;数字三角形→_→

题解: DP


AC代码:

#include<iostream>
#include<cstring>
#define N 105
using namespace std;
int dp[N][N],n;
int main()
{
    cin.sync_with_stdio(false);
    while(cin>>n){
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
            for(int j=0;j<=i;j++)cin>>dp[i][j];
         for(int i=n-2;i>=0;i--)
         for(int j=0;j<=i;j++){
            dp[i][j]+=max(dp[i+1][j],dp[i+1][j+1]);
         }
         cout<<dp[0][0]<<endl;
    }
    return 0;
}




POJ 1163 The Triangle

原文:http://blog.csdn.net/mummyding/article/details/43538929

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!