Problem Description
As we know, Big Number is always troublesome. But it‘s really important in our ACM. And today, your task is to write a program to calculate A mod B.
To make the problem easier, I promise that B will be smaller than 100000.
Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
Output
For each test case, you have to ouput the result of A mod B.
Sample Input
2 3
12 7
152455856554521 3250
Sample Output
代码如下:
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
int n,sum,i,k;
char s[1001];
while(cin>>s>>n)
{
k=strlen(s);
sum=0;
for(i=0; i<k; i++)
{
sum=sum*10+s[i]-'0';
sum=sum%n;
}
cout<<sum<<endl;
}
return 0;
}
YT14-HDU-取余
原文:http://blog.csdn.net/liuchang54/article/details/43538917