首页 > 其他 > 详细

POJ 3258 River Hopscotch (二分)

时间:2015-02-06 13:17:49      阅读:143      评论:0      收藏:0      [点我收藏+]


River Hopscotch
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 7793   Accepted: 3356

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ MN).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

Source

USACO 2006 December Silver

题目链接:http://poj.org/problem?id=3258

题目大意:一个长为L的河,河两边都有石子分别为起点和终点,河中间有n个石子,每个石子到起点的距离为di,现在要从这n个石子中删去m个,使得任意两个石子间的最短距离最大。

题目分析:又是这种求最小中最大的题,典型的二分题,我们先将距离排序,虽然石子顺序是确定的,但是排完序不影响它们之间的差值,二分的上限是河长L,下限是两个最短的石头间的距离,二分的是石子间距离的划分值,接着开始枚举,如果差值小于划分值则累计差值,并且删去这个石头,否则累计量归0,如果按当前划分值划分出来要删的石子数大于m,则说明当前划分值较大。

#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
int d[50005];

int main()
{
    int l, n, m, mi = 2 * 1e9;
    scanf("%d %d %d", &l, &n, &m);
    d[0] = 0;
    d[n + 1] = l;
    for(int i = 1; i <= n; i++)
        scanf("%d", &d[i]);
    sort(d, d + n + 1);
    for(int i = 0; i <= n; i++)
        if(d[i + 1] - d[i] < mi)
            mi = d[i + 1] - d[i];
    int le = mi, ri = l, mid = (le + ri) / 2;
    while(le <= ri)
    {
        int cnt = 0, tmp = 0;
        for(int i = 1; i <= n; i++)
        {
            if(tmp + d[i] - d[i - 1] < mid)
            {
                tmp += (d[i] - d[i - 1]);
                cnt ++;
            }
            else
                tmp = 0;
        }
        if(cnt > m)
            ri = mid - 1;
        else
            le = mid + 1;
        mid = (le + ri) / 2;
    }
    printf("%d\n", mid);
}


POJ 3258 River Hopscotch (二分)

原文:http://blog.csdn.net/tc_to_top/article/details/43562157

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!