首页 > 其他 > 详细

POJ 3984 迷宫问题 (路径记录)

时间:2015-02-06 16:43:59      阅读:265      评论:0      收藏:0      [点我收藏+]
K - 迷宫问题
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

定义一个二维数组:        
int maze[5][5] = {

 0, 1, 0, 0, 0,

 0, 1, 0, 1, 0,

 0, 0, 0, 0, 0,

 0, 1, 1, 1, 0,

 0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。      

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。      

Output

左上角到右下角的最短路径,格式如样例所示。      

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

 

 

刚学的记录路径。

不过BFS的部分不是我以前那种写法,还是感觉有点生涩。

其他大体上差不多吧。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int map[6][6];
int rear=1;
int front=0;
struct node
{
	int x,y;
	int pre;
}
;
node q[36];
void output(int i)
{
	if(q[i].pre!=-1)
	{
		output(q[i].pre);//用递归输出路径。
		printf("(%d, %d)\n",q[i].x,q[i].y);
	}
}
void bfs(int x,int y)
{
	int i;
	q[front].x=x;
	q[front].y=y;
	q[front].pre=-1;
	map[x][y]=1;
	while(front<rear)
	{
		for(i=0;i<4;i++)
		{
			int nx=q[front].x+dir[i][0];
			int ny=q[front].y+dir[i][1];
			if(nx>=5 ||nx<0 ||ny>=5 ||ny<0 ||map[nx][ny])
				continue;
			map[nx][ny]=1;
			q[rear].x=nx;
			q[rear].y=ny;
			q[rear++].pre=front;//入队+记录路径。
			if(nx==4 &&ny==4)
				output(front);
		}
		front++;//出队
	}
}
int main()
{
    int i,j;
	for(i=0;i<5;i++)
		for(j=0;j<5;j++)
			scanf("%d",&map[i][j]);
		printf("(0, 0)\n");
		bfs(0,0);
		printf("(4, 4)\n");	
}


 

POJ 3984 迷宫问题 (路径记录)

原文:http://blog.csdn.net/sky_miange/article/details/43565801

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!