首页 > 其他 > 详细

HDOJ 2817 A sequence of numbers【快速幂取模】

时间:2015-02-07 23:02:42      阅读:462      评论:0      收藏:0      [点我收藏+]

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2817

A sequence of numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3754    Accepted Submission(s): 1152


Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
 

Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 

Output
Output one line for each test case, that is, the K-th number module (%) 200907.
 

Sample Input
2 1 2 3 5 1 2 4 5
 

Sample Output
5 16
 

Source
 

题意:是我E文太差or理解能力不行?! 题目只说给出sequence的前三项啊,没说什么
       不是等差就是等比啊....呜呜...  好吧,它本意是先要判断是等差还是等比,然后要
       求算出第k项模上200907的结果。
题解:快速幂模板题,特别小心别超long long 型.. 我居然没看输入格式——WA了几发....
AC代码:
#include<iostream>
#define Mod 200907
#define LL long long
using namespace std;
LL x,y,z,k,sum,t;
LL pow_mod(LL m,LL k){
    if(k==0)return 1;
    if(k==1)return m%Mod;
    LL ans=pow_mod(m,k/2);
    ans=(ans*ans)%Mod;
    if(k&1)ans=(ans*m)%Mod;
    return ans;
}
int main()
{
    cin.sync_with_stdio(false);
    cin>>t;
    while(t--){
        cin>>x>>y>>z>>k;
        bool flag=false;
        if(y-x==z-y)flag=true;
        if(flag){
            LL d=y-x;
            sum=(x%Mod+(k-1)*(d%Mod)%Mod)%Mod;
        }
        else {
            LL q=y/x;
            sum=((x%Mod)*pow_mod(q,k-1))%Mod;
        }
        cout<<sum<<endl;
    }
    return 0;
}

【转载请注明出处】
作者:MummyDing




HDOJ 2817 A sequence of numbers【快速幂取模】

原文:http://blog.csdn.net/mummyding/article/details/43611645

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!