首页 > 其他 > 详细

HDU 5170 GTY's math problem (bsst code #29 1001)

时间:2015-02-08 09:07:22      阅读:254      评论:0      收藏:0      [点我收藏+]

GTY‘s math problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 146    Accepted Submission(s): 80


Problem Description
GTY is a GodBull who will get an Au in NOI . To have more time to learn algorithm knowledge, he never does his math homework. His math teacher is very unhappy for that, but she can‘t do anything because GTY can always get a good mark in math exams. One day, the math teacher asked GTY to answer a question. There are four numbers on the blackboard - a,b,c,d技术分享. The math teacher wants GTY to compare a技术分享b技术分享技术分享 with c技术分享d技术分享技术分享. Because GTY never does his homework, he can‘t figure out this problem! If GTY can‘t answer this question correctly, he will have to do his homework. So help him!
 

Input
Multi test cases (about 5000). Every case contains four integers a,b,c,d(1a,b,c,d1000技术分享)separated by spaces. Please process to the end of file.
 

Output
For each case , if a技术分享b技术分享>c技术分享d技术分享技术分享 , print ‘>‘. if a技术分享b技术分享<c技术分享d技术分享技术分享 , print ‘<‘. if a技术分享b技术分享=c技术分享d技术分享技术分享 , print ‘=‘.
 

Sample Input
2 1 1 2 2 4 4 2 10 10 9 11
 

Sample Output
> = <
 

Source

 

这个数据一看就知道不能用普通的方法。

1000的1000次方。

C语言无法表达的。

可以想到用对数。

比较log(a^b) 和log(c^d)的大小

而log(a^b)=b*log(a);

log(c^d)=d*log(c);

OK

可以写代码了。

控制到12点后十二位就可以认为它们相等了

#include <stdio.h>
#include <math.h>
#define eps 1e-12  //10的负十二次方
int main()
{
	double a,b,c,d;
	while(scanf("%lf%lf%lf%lf",&a,&b,&c,&d)!=EOF)
	{
		double s,s1;
		s=b*log(a);
		s1=d*log(c);
		if(a==1 &&c==1)  //等于肯定都是相等的
		{
			printf("=\n");
			continue;
		}  
		if(fabs(s-s1)<eps)     //对数计算后,相差只要不超过10的负十二次方,就可以认为它们相等。
			printf("=\n"); 
		else if(s>s1)
			printf(">\n");
		else  if(s<s1)
			printf("<\n");
	}
	return 0;
}


 

HDU 5170 GTY's math problem (bsst code #29 1001)

原文:http://blog.csdn.net/sky_miange/article/details/43611547

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!