首页 > 其他 > 详细

Ugly Numbers

时间:2014-03-06 23:28:00      阅读:627      评论:0      收藏:0      [点我收藏+]
Ugly Numbers
时间限制: 1 Sec  内存限制: 128 MB
题目描述
Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence 1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ... shows the first 10 ugly numbers. By convention, 1 is included. Given the integer n,write a program to find and print the n‘th ugly number.
输入
Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.
输出
For each line, output the n’th ugly number .:Don’t deal with the line with n=0.
样例输入
1
2
9
0
样例输出
1
2

10


// Ugly Numbers
//只能被2,3,5整除,1,2,3,4,5,6,8,9,10...
#include <stdio.h>
//在已知第一个丑数基础上,分别进行*2,*3,*5操作,然后取最小的依次放入数组
//即可避免所有数字暴力穷举选择 
int twoNum = 0, threeNum = 0, fiveNum = 0;
int ugly[1500];
void create()
{
    ugly[0] = 1;
    for (int i = 1; i < 1500; i++) {
        int min = ugly[twoNum] * 2, b = ugly[threeNum] * 3, c = ugly[fiveNum] * 5;
        if (b < min) {
            min = b;
        }
        if (c < min) {
            min = c;
        }
        ugly[i] = min;
        if (ugly[i] == ugly[twoNum] * 2) {
            twoNum++;
        }
        if (ugly[i] == ugly[threeNum] * 3) {
            threeNum++;
        }
        if (ugly[i] == ugly[fiveNum] * 5) {
            fiveNum++;
        }
    }
}
 
int main()
{
    create();
    int n;
    while (scanf("%d", &n) != EOF) {
        if (n == 0) {
            return 0;
        }
        printf("%d\n", ugly[n - 1]);
    }
    return 0;
}

Ugly Numbers,布布扣,bubuko.com

Ugly Numbers

原文:http://blog.csdn.net/u013240812/article/details/20633229

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!