首页 > 其他 > 详细

Geometry Made Simple

时间:2015-02-13 22:27:21      阅读:401      评论:0      收藏:0      [点我收藏+]

Geometry Made Simple

Description

Mathematics can be so easy when you have a computer. Consider the following example. You probably know that in a right-angled triangle, the length of the three sides a, b, c (where c is the longest side, called the hypotenuse) satisfy the relation a*a+b*b=c*c. This is called Pythagora’s Law.

Here we consider the problem of computing the length of the third side, if two are given.

Input

The input contains the descriptions of several triangles. Each description consists of a line containing three integers a, b and c, giving the lengths of the respective sides of a right-angled triangle. Exactly one of the three numbers is equal to -1 (the ‘unknown’ side), the others are positive (the ‘given’ sides).

A description having a=b=c=0 terminates the input.

Output

For each triangle description in the input, first output the number of the triangle, as shown in the sample output. Then print “Impossible.” if there is no right-angled triangle, that has the ‘given’ side lengths. Otherwise output the length of the ‘unknown’ side in the format “s = l”, where s is the name of the unknown side (a, b or c), and l is its length. l must be printed exact to three digits to the right of the decimal point.

Print a blank line after each test case.

Sample Input

3 4 -1
-1 2 7
5 -1 3
0 0 0

Sample Output

Triangle #1
c = 5.000

Triangle #2
a = 6.708

Triangle #3
Impossible.
题意分析:这是一道三角形的勾股定理的题目,这道题目的题意大体是按顺序输入a、b、c三条边, c为斜边,如果输入-1表示该边为未知边,求此边长度,如果没有,输出不可能。
下面给一下代码:

#include<stdio.h>
#include<math.h>
int main()
{
    int i=1;
    int  a, b, c;
    double x;
    while(scanf("%d %d %d",&a, &b, &c)==3)
    {
        x=0;
        if(a==0&&b==0&&c==0)
        {
            break;
        }
        printf("Triangle #%d\n",i);
        if(a==-1)
        {
            x=c*c-b*b;
            if(x<0)
            {
                printf("Impossible.\n");
            }
            else
            {
                printf("a = %.3f\n",(double)sqrt(x));
            }

        }
        else if(b==-1)
        {
            x=c*c-a*a;
            if(x<0)
            {
                printf("Impossible.\n");
            }
            else
            {
                printf("b = %.3f\n",(double)sqrt(x));
            }

        }
        else
        {
            x=a*a+b*b;
            if(x<0)
            {
                printf("Impossible.\n");
            }
            else
            {
                printf("c = %.3f\n",(double)sqrt(x));
            }

        }
         i++;
         printf("\n");
    }
    return 0;
}

Geometry Made Simple

原文:http://blog.csdn.net/unusualnow/article/details/43802087

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!