首页 > 其他 > 详细

一道简单题——A Simple Task

时间:2015-02-19 00:16:41      阅读:397      评论:0      收藏:0      [点我收藏+]

就像这道题的题目一样,真的是一个简单的题目,题意就是一句话:给一个数N求符合公式N = O * 2P的 O 和 P。

下面我们就一起看一下题吧。

Description

Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.

Example

For n = 24, o = 3 and p = 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the odd integer o and the nonnegative integer p such that n = o2^p,

writes the result.

Input

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

Output

The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.

Sample Input

1
24

Sample Output
3 3

先给看一下我曾经提交很多次,但都超时的代码

#include<stdio.h>
int main()
{
    int d, n, o, p;
    while(scanf("%d",&d)==1)
    {
        for(int j=1;j<=d;j++)
        {
            scanf("%d",&n);
            o=1;
            p=1;
            if(n==1)
            {
                printf("0 1\n");
            }
            for(int i=2;j<n;i*=2)
            {

                if(n==o*i)
                {
                    break;
                }
                else
                {
                    o++;
                    p++;
                }
            }
            printf("%d %d\n",o,p);
        }
    }
    return 0;
}

看过我的代码之后,是不是觉得没问题呀,恩,反正当初我觉得就是对,但是,你可以把我的代码自己运行一下,测试数据随便取个奇数就ok啦,如3 23,哎,当初我测试的时候就没测试奇数,测试的全是偶数,XX还嘲笑我。后来得知超时主要是这几个原因:1.算法太简单2.效率太低,前面提到过,编程很讲究效率的3.程序遇到某种测试数据导致死循环。OK,下面看一下我提交后过了的代码吧。

#include<stdio.h>
int main()
{
    int d,n,j;
    while(~scanf("%d",&d))
    {
        for(int i=0;i<d;i++)
        {
            scanf("%d",&n);
            j=0;
            while(n%2==0)
            {   
                j++;
                n=n/2;     
            }    
            printf("%d %d\n",n,j);
        }
    }
    return 0;
}

这道题还是要从数的奇偶性出发。做了这道题之后,我懂得一个道理,就是如果在这方面行不通的话,就别再执着了,换个角度,换个思路,会是一片光明大道的。

一道简单题——A Simple Task

原文:http://blog.csdn.net/unusualnow/article/details/43878797

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!