首页 > 其他 > 详细

nefu 628大组合数取模

时间:2015-03-03 09:57:11      阅读:110      评论:0      收藏:0      [点我收藏+]

题目连接:http://acm.nefu.edu.cn/JudgeOnline/problemshow.php?problem_id=628

关于ACM培训的通知

Garden visiting

Problem : 628

Time Limit : 1000ms

Memory Limit : 65536K

description

There is a very big garden at Raven’s residence. We regard the garden as an n*m rectangle. Raven’s house is at the top left corner, and the exit of the garden is at the bottom right. He can choose to take one step to only one direction (up, down, left or right) each time. Raven wants to go out of the garden as quickly as possible, so he wonders how many routes he could choose. 
Raven knows there are many possible routes, so he only wants to know the number, which is the result that the total number of possible routes modes a given value p. He knows it is a simple question, so he hopes you may help him to solve it. 

input

The first line of the input contains an integer T, which indicates the number of test cases.
Then it is followed by three positive integers n, m and p (1 <= n, m, p <= 10^5), showing the length and width of the garden and p to be the mod of the result. 

output

For each case, output one number to show the result (the sum modes p).

sample_input

3
2 2 5
2 6 16
6 6 24

sample_output

2
6
12

hint

Sample 1: There are 2 routes in total. 
Sample 2: There are 6 routes in total.
Sample 3: There are 252 routes in total.

分析:题中的n,m比较大,显然不能用杨辉三角

那么可以这样考虑:C(n,m)= n!/(m!*(n-m)!)   将分子和分母分别转化为素因子乘积的形式,然后上下同时约去,最后用快速幂搞一下就行了

如果p为素数的话,那么可以用lucas定理搞~

#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
const int N=1e5+100;
using namespace std;
typedef long long ll;

int n,m,p,ct;
ll prime[2*N];
bool isprime[2*N];
int t[5][2*N];

void solve()
{
   ct=0;
   memset(isprime,false,sizeof(isprime));
   isprime[0]=isprime[1]=true;
   for(int i=2;i<=200100;i++)
   {
     if(!isprime[i])
     {
       prime[++ct]=i;
       for(int j=i+i;j<=200100;j+=i)
       isprime[j]=true;
     }
   }
}

int cal(int x,int pos)
{
   int i=1;
   for(;i<=ct&&prime[i]<=x;i++)
   {
       int ans=0,tmp=prime[i];
       while(x/tmp!=0)
       {
         ans+=x/tmp;
         tmp*=prime[i];
       }
       t[pos][i]=ans;
   }
   return i;
}

ll quick(ll a,int b )
{
   ll ans=1;
   while(b)
   {
      if(b&1)ans=ans*a%p;
      b=b/2;
      a=a*a%p;
   }
   return ans;
}

int main()
{
   int T;
   scanf("%d",&T);
   solve();
   while(T--)
   {
     scanf("%d%d%d",&n,&m,&p);
     memset(t,0,sizeof(t));

     if(n-1==0)
        {
            printf("1\n");
            continue;
        }
     if(n-1==1)
        {
            printf("%d\n",(n+m-2)%p);
            continue;
        }

     int t1=cal(n+m-2,1);
     int t2=cal(n-1,2);
     int t3=cal(m-1,3);
     int cnt=max(t1,max(t2,t3));

     for(int i=1;i<cnt;i++)
     {
       t[1][i]=t[1][i]-t[2][i]-t[3][i];
     }


     ll ans=1;
     for(int i=1;i<cnt;i++)
     {
         ans=ans*quick(prime[i],t[1][i])%p;
     }
     printf("%lld\n",ans);

   }
   return 0;
}


nefu 628大组合数取模

原文:http://blog.csdn.net/liusuangeng/article/details/44026067

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!