首页 > 其他 > 详细

Power of Cryptography

时间:2015-03-04 14:17:23      阅读:228      评论:0      收藏:0      [点我收藏+]

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest. 
This problem involves the efficient computation of integer roots of numbers. 
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is what your program must find).

Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn = p.

Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

Sample Input

2 16
3 27
7 4357186184021382204544

Sample Output

4
3
1234

Source

大意:利用二分法(log2n)不会超时
技术分享
#include<cstdio>
#include<math.h>
int main(){
    double p,n,k;
    long long int   end,mid,begin;
    while(~scanf("%lf%lf",&n,&p)){
            end = 1000000000,begin = 1;
            while(begin <= end){
                      mid = (begin + end )/2 ;
                 k =pow(mid,n);
                   if(k<p){
                    begin = mid  ;
                    }
                   else if (k>p){
                    end = mid ;}
                   else {
                        printf("%lld\n",mid);
                    break;
              }
            }
    }
    return 0;
}
View Code

 

Power of Cryptography

原文:http://www.cnblogs.com/zero-begin/p/4313146.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!