Treats for the Cows
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 4259 |
|
Accepted: 2150 |
Description
FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.
The treats are interesting for many reasons:
- The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
- Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
- The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
- Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?
The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input
Line 1: A single integer, N
Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output
Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input
5
1
3
1
5
2
Sample Output
43
Hint
Explanation of the sample:
Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).
FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.
Source
#include<stdio.h>
#include<iostream>
#include<math.h>
#include<stdlib.h>
#include<ctype.h>
#include<algorithm>
#include<vector>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
using namespace std;
int m, n, p[10010],dp[2010][2010];
int main()
{
while (cin >> n)
{
for (int i = 1; i <= n; i++)
cin >> p[i];
for (int i = 0; i <= n; i++)
for (int j = 0; j <= n; j++)
dp[i][j] = 0;
for (int i = 1; i <= n; i++)
dp[i][i] = p[i] * n;//初始化为最大。
for (int len = 1; len < n; len++)
{
for (int i = 1; i + len <= n; i++)
{
int j = i + len;
dp[i][j] = max(dp[i + 1][j] + (n - len)*p[i], dp[i][j - 1] + (n - len)*p[j]);//从内向外dp,i j 代表区间范围。
}
}
cout << dp[1][n] << endl;
}
return 0;
}
poj-3816 Treats for the Cows 【区间DP】
原文:http://blog.csdn.net/u014427196/article/details/44064101