首页 > 其他 > 详细

Pat(Advanced Level)Practice--1030(Travel Plan)

时间:2014-03-09 17:18:59      阅读:504      评论:0      收藏:0      [点我收藏+]

Pat1030代码

题目描述:

A traveler‘s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40

AC代码:
#include<cstdio>
#include<vector>
#define MAX 501
#define INF 0x0FFFFFFF

using namespace std;

int map[MAX][MAX],cost[MAX][MAX];
int length[MAX],mincost[MAX];
int path[MAX],visited[MAX];

void Init(int n)
{
	int i,j;
	for(i=0;i<n;i++)
	{
		length[i]=mincost[i]=INF;
		for(j=0;j<n;j++)
		{
			map[i][j]=INF;
			cost[i][j]=INF;
		}
	}
}

void Dijkstra(int start,int n,int end)
{
	int i,j,k;
	int min=INF,t_cost;
	for(i=0;i<n;i++)
	{
		if(map[start][i]!=INF)
			length[i]=map[start][i];
		if(cost[start][i]!=INF)
			mincost[i]=cost[start][i];
		path[i]=start;
	}
	length[start]=0;
	mincost[start]=0;
	visited[start]=1;
	for(i=1;i<n;i++)
	{
		min=INF;
		for(j=0;j<n;j++)
		{
			if(!visited[j]&&length[j]<min)
			{
				k=j;
				min=length[j];
				t_cost=mincost[j];
			}
		}
		visited[k]=1;
		for(j=0;j<n;j++)
		{
			if(!visited[j]&&length[j]>map[k][j]+min)
			{
				length[j]=map[j][k]+min;
				mincost[j]=cost[j][k]+t_cost;
				path[j]=k;
			}
			else if(!visited[j]&&length[j]==map[k][j]+min
				&&mincost[j]>t_cost+cost[k][j])
			{
				length[j]=map[k][j]+min;
				mincost[j]=cost[k][j]+t_cost;
				path[j]=k;
			}
		}
	}                        //path[]中存储的是前驱节点,path[i]=k;
	int stack[MAX],top=-1;  //表示进过节点k到达i
	int index=end;
	while(index!=start)
	{
		stack[++top]=index;
		index=path[index];
	}
	printf("%d",start);
	while(top>-1)
	{
		printf(" %d",stack[top]);
		top--;
	}
	printf(" %d %d\n",length[end],mincost[end]);
}

int main(int argc,char *argv[])
{
	int n,m,s,d;
	int i;
	scanf("%d%d%d%d",&n,&m,&s,&d);
    Init(n);
	for(i=0;i<m;i++)
	{
		int a,b,l,c;
		scanf("%d%d%d%d",&a,&b,&l,&c);
		if(map[a][b]>l||(map[a][b]==l&&cost[a][b]>c))//取重复路径中短的和花费
		{                                            //少的
			map[a][b]=map[b][a]=l;
		  	cost[a][b]=cost[b][a]=c;
		}
	}
	Dijkstra(s,n,d);
	return 0;
}


Pat(Advanced Level)Practice--1030(Travel Plan),布布扣,bubuko.com

Pat(Advanced Level)Practice--1030(Travel Plan)

原文:http://blog.csdn.net/cstopcoder/article/details/20832275

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!