首页 > 其他 > 详细

uva 147 Dollars(DP)

时间:2015-03-15 15:18:03      阅读:409      评论:0      收藏:0      [点我收藏+]

                     uva 147 Dollars


New Zealand currency consists of $100, $50, $20, $10, and $5 notes and $2, $1, 50c, 20c, 10c and 5c coins. Write a program that will determine, for any given amount, in how many ways that amount may be made up. Changing the order of listing does not increase the count. Thus 20c may be made up in 4 ways: 1 技术分享 20c, 2 技术分享 10c, 10c+2 技术分享 5c, and 4 技术分享 5c.

Input

Input will consist of a series of real numbers no greater than $300.00 each on a separate line. Each amount will be valid, that is will be a multiple of 5c. The file will be terminated by a line containing zero (0.00).

Output

Output will consist of a line for each of the amounts in the input, each line consisting of the amount of money (with two decimal places and right justified in a field of width 6), followed by the number of ways in which that amount may be made up, right justified in a field of width 17.

Sample input

0.20
2.00
0.00

Sample output

  0.20                4
  2.00              293



题目大意:给出一个金额数,问用11种面值的货币,有几种组成方式。

解题思路:注意对题目给出的金额数的处理,还有输出的规范要看清。



#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
using namespace std;

int coin[11] = {10000, 5000, 2000, 1000, 500, 200, 100, 50, 20, 10, 5};
long long dp[80005];

int main() {
	int a, b;
	while (scanf("%d.%d", &a, &b) == 2) {

		if (a == 0 && b == 0) break;
		int n = a * 100 + b;	
		memset(dp, 0, sizeof(dp));
		dp[0] = 1;

		for (int i = 10; i >= 0; i--) {
			for (int j = coin[i]; j <= n; j++) {
				if (dp[j - coin[i]]) {
					dp[j] += dp[j - coin[i]];
				}
			}
		}

		printf("%3d.%.2d%17.lld\n", a, b, dp[n]);
	}
	return 0;
}



uva 147 Dollars(DP)

原文:http://blog.csdn.net/llx523113241/article/details/44277091

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!