首页 > 其他 > 详细

HDU3485 && CSU1363:Count 101

时间:2014-03-09 20:38:45      阅读:560      评论:0      收藏:0      [点我收藏+]
Problem Description
You know YaoYao is fond of his chains. He has a lot of chains and each chain has n diamonds on it. There are two kinds of diamonds, labeled 0 and 1. We can write down the label of diamonds on a chain. So each chain can be written as a sequence consisting of 0 and 1.
We know that chains are different with each other. And their length is exactly n. And what’s more, each chain sequence doesn’t contain “101” as a substring. 
Could you tell how many chains will YaoYao have at most?
 

Input
There will be multiple test cases in a test data. For each test case, there is only one number n(n<10000). The end of the input is indicated by a -1, which should not be processed as a case.
 

Output
For each test case, only one line with a number indicating the total number of chains YaoYao can have at most of length n. The answer should be print after module 9997.
 

Sample Input
3 4 -1
 

Sample Output
7 12
Hint
We can see when the length equals to 4. We can have those chains: 0000,0001,0010,0011 0100,0110,0111,1000 1001,1100,1110,1111
 


 

这道题我纯粹是靠列出一些数字找规律的。。。

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int mod = 9997;
int a[10005] = {0,2,4,7,12};

int main()
{
    int i;
    for(i = 5; i<=10000; i++)
        a[i] = (a[i-1]+a[i-2]+a[i-4])%mod;
    while(~scanf("%d",&i),i!=-1)
        printf("%d\n",a[i]);

    return 0;
}


 

HDU3485 && CSU1363:Count 101,布布扣,bubuko.com

HDU3485 && CSU1363:Count 101

原文:http://blog.csdn.net/libin56842/article/details/20856025

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!