首页 > 其他 > 详细

poj3321之将树转化为一维树状数组

时间:2014-03-09 20:46:47      阅读:528      评论:0      收藏:0      [点我收藏+]

Language:
Apple Tree
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 17342   Accepted: 5272

Description

There is an apple tree outside of kaka‘s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won‘t grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

bubuko.com,布布扣

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef long long LL;
using namespace std;

const int MAX=100000+10;
int n,q,size;
bool a[MAX];
int head[MAX],c[MAX],start[MAX],end[MAX];

struct Edge{
	int v,next;
	Edge(){}
	Edge(int V,int NEXT):v(V),next(NEXT){}
}edge[MAX];

void Init(int num){
	for(int i=0;i<=num;++i)head[i]=-1,a[i]=false;
	size=0;
}

void InsertEdge(int u,int v){
	edge[size]=Edge(v,head[u]);
	head[u]=size++;
}

void dfs(int u){
	start[u]=++size;
	for(int i=head[u];i != -1;i=edge[i].next){
		int v=edge[i].v;
		dfs(v);
	}
	end[u]=size;
}

int lowbit(int x){
	return x&(-x);
}

void Update(int x,int y,int d){
	while(x<=y){
		c[x]+=d;
		x+=lowbit(x);
	}
}

int Query(int x){
	int sum=0;
	while(x>0){
		sum+=c[x];
		x-=lowbit(x);
	}
	return sum;
}

int main(){
	int u,v;
	char op[3];
	while(~scanf("%d",&n)){
		Init(n);
		memset(c,0,sizeof c);
		for(int i=1;i<n;++i){
			scanf("%d%d",&u,&v);
			InsertEdge(u,v);
			a[u]=a[v]=true;
		}
		size=0;
		dfs(1);
		for(int i=1;i<=n;++i){
			if(a[i] == 1)Update(start[i],end[1],1);
		}
		scanf("%d",&q);
		for(int i=0;i<q;++i){
			scanf("%s%d",op,&u);
			if(op[0] == ‘C‘){
				if(a[u])Update(start[u],end[1],-1);
				else Update(start[u],end[1],1);
				a[u]=!a[u];
			}else{
				printf("%d\n",Query(end[u])-Query(start[u]-1));
			}
		}
	}
	return 0; 
} 



poj3321之将树转化为一维树状数组,布布扣,bubuko.com

poj3321之将树转化为一维树状数组

原文:http://blog.csdn.net/xingyeyongheng/article/details/20852325

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!