Matrix
Time Limit: 3000MS |
|
Memory Limit: 65536K |
Total Submissions: 16661 |
|
Accepted: 6260 |
Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a ‘0‘ then change it into ‘1‘ otherwise change
it into ‘0‘). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].
Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above.
Output
For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.
Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1
Sample Output
1
0
0
1
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef long long LL;
using namespace std;
const int MAX=1000+10;
int n,q;
int c[MAX][MAX];
int lowbit(int x){
return x&(-x);
}
void Update(int x,int y){
while(x<=n){
int y1=y;
while(y1<=n){
c[x][y1]+=1;
y1+=lowbit(y1);
}
x+=lowbit(x);
}
}
int Query(int x,int y){
int sum=0;
while(x>0){
int y1=y;
while(y1>0){
sum+=c[x][y1];
y1-=lowbit(y1);
}
x-=lowbit(x);
}
return sum;
}
int main(){
int t,x1,y1,x2,y2;
char op[2];
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&q);
memset(c,0,sizeof c);
for(int i=0;i<q;++i){
scanf("%s",op);
if(op[0] == ‘C‘){
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
Update(x1,y1);
Update(x1,y2+1);
Update(x2+1,y1);
Update(x2+1,y2+1);
}else{
scanf("%d%d",&x1,&y1);
printf("%d\n",Query(x1,y1)%2);
}
}
printf("\n");
}
return 0;
}
poj2155之二维树状数组,布布扣,bubuko.com
poj2155之二维树状数组
原文:http://blog.csdn.net/xingyeyongheng/article/details/20852159