首页 > 其他 > 详细

hdu2412Party at Hali-Bula (树形DP+记录是否唯一)

时间:2014-03-10 22:59:28      阅读:705      评论:0      收藏:0      [点我收藏+]
Problem Description
Dear Contestant,

I‘m going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I‘ve attached the list of employees and the organizational hierarchy of BCM.

Best,
--Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.

Input
The input consists of multiple test cases. Each test case is started with a line containing an integer n (1 ≤ n ≤ 200), the number of BCM employees. The next line contains the name of the Big Boss only. Each of the following n-1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.

Output
For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.

Sample Input
6 Jason Jack Jason Joe Jack Jill Jason John Jack Jim Jill 2 Ming Cho Ming 0

Sample Output
4 Yes 1 No
题意:第一行给出一个数n,表示n个人形成一棵关系树,第二行给出一个人名表示的是根节点,接下来n-1行描述的是两人有直接的上下级关系。问找出参加party的人中任意两人之间没有直接的上下级关系的最多人数,并且判断组成的人数是否唯一。
#include<stdio.h>
#include<iostream>
#include<map>
#include<string>
using namespace std;
struct nnn
{
    int k;
    int son[205];
}node[205];
int vist[205],dp[205][2],only[205][2];//dp[p][i],i=0表示节点p不参与,i=1表示参与
int max(int a,int b)
{
    return a>b?a:b;
}
void dfs(int p)
{
    dp[p][0]=0; dp[p][1]=1; vist[p]=1;
    only[p][0]=only[p][1]=1;//表示唯一
    for(int i=1;i<=node[p].k;i++)
    {
        int son=node[p].son[i];
        if(vist[son])continue;
        dfs(son);

        dp[p][1]+=dp[son][0];
        if(!only[son][0])
                only[p][1]=0;
        dp[p][0]+=max(dp[son][0],dp[son][1]);
        if(dp[son][0]>dp[son][1]&&only[son][0]==0)only[p][0]=0;
        if(dp[son][0]<dp[son][1]&&only[son][1]==0)only[p][0]=0;
        if(dp[son][0]==dp[son][1]) only[p][0]=0;
    }
}
int main()
{
    int n,m,a,b,k,maxsum;
    char str[2][150];
    map<string,int>name;
    while(scanf("%d",&n)>0&&n)
    {
        m=0; name.clear();
        for(int i=0;i<=n+2;i++)
        vist[i]=0,node[i].k=0;

        scanf("%s",str[0]);
        m++; name[str[0]]=m;
        for(int i=1;i<n;i++)
        {
            scanf("%s%s",str[0],str[1]);
            if(!name[str[0]])
            {
                m++; name[str[0]]=m;
            }
            if(!name[str[1]])
            {
                m++; name[str[1]]=m;
            }
            a=name[str[0]]; b=name[str[1]];
            node[a].k++; k=node[a].k; node[a].son[k]=b;
            node[b].k++; k=node[b].k; node[b].son[k]=a;
        }
        dfs(1);
        int onl=1;
        maxsum=max(dp[1][0],dp[1][1]);
        if(dp[1][0]>dp[1][1]&&only[1][0]==0)onl=0;
        if(dp[1][0]<dp[1][1]&&only[1][1]==0)onl=0;
        if(dp[1][0]==dp[1][1]) onl=0;

        printf("%d %s\n",maxsum,onl?"Yes":"No");
    }
}


hdu2412Party at Hali-Bula (树形DP+记录是否唯一),布布扣,bubuko.com

hdu2412Party at Hali-Bula (树形DP+记录是否唯一)

原文:http://blog.csdn.net/u010372095/article/details/20942939

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!