首页 > 编程语言 > 详细

应用归并排序(求逆序数)

时间:2015-03-26 20:35:18      阅读:210      评论:0      收藏:0      [点我收藏+]

Description

技术分享In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
大意:求冒泡排序交换的个数,也就是求逆序数,套一下模板
技术分享
#include<cstring>
#include<cstdio>
#include<algorithm>
const int MAX = 510000;
int a[MAX],temp[MAX];
int ans = 0;
void mergesort(int *a,int first,int mid,int last,int *temp)
{
   int i = first,j = mid + 1;
   int  k = first;
    while( i <= mid && j <= last){
          if(a[i] <= a[j])
          temp[k++] = a[i++];
          else {
            ans += j - k;
           temp[k++] = a[j++];
          }
    }
    while( i <= mid)
        temp[k++] = a[i++];
    while( j <= last)
        temp[k++] = a[j++];
    for(int i = first;i <= last;i++)
        a[i] = temp[i];
}
void mergearray(int *a,int first,int last,int *temp)
{
     if(first < last){
            int mid = (first + last) >> 1;
            mergearray(a,first,mid,temp);
            mergearray(a,mid+1,last,temp);
            mergesort(a,first,mid,last,temp);
     }
}
int main()
{
    int n;
    scanf("%d",&n);
    for(int i = 1; i <= n; i++)
    scanf("%d",&a[i]);
    mergearray(a,1,n,temp);
    printf("%d",ans);
  return 0;
}
View Code

 

 

应用归并排序(求逆序数)

原文:http://www.cnblogs.com/zero-begin/p/4369654.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!