首页 > 其他 > 详细

HDU 5074 Hatsune Miku 暴力dp

时间:2015-03-26 20:53:59      阅读:219      评论:0      收藏:0      [点我收藏+]

Hatsune Miku

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 677    Accepted Submission(s): 490


Problem Description
Hatsune Miku is a popular virtual singer. It is very popular in both Japan and China. Basically it is a computer software that allows you to compose a song on your own using the vocal package.

Today you want to compose a song, which is just a sequence of notes. There are only m different notes provided in the package. And you want to make a song with n notes.

技术分享

Also, you know that there is a system to evaluate the beautifulness of a song. For each two consecutive notes a and b, if b comes after a, then the beautifulness for these two notes is evaluated as score(a, b).

So the total beautifulness for a song consisting of notes a1, a2, . . . , an, is simply the sum of score(ai, ai+1) for 1 ≤ i ≤ n - 1.

Now, you find that at some positions, the notes have to be some specific ones, but at other positions you can decide what notes to use. You want to maximize your song’s beautifulness. What is the maximum beautifulness you can achieve?
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers n(1 ≤ n ≤ 100) and m(1 ≤ m ≤ 50) as mentioned above. Then m lines follow, each of them consisting of m space-separated integers, the j-th integer in the i-th line for score(i, j)( 0 ≤ score(i, j) ≤ 100). The next line contains n integers, a1, a2, . . . , an (-1 ≤ ai ≤ m, ai ≠ 0), where positive integers stand for the notes you cannot change, while negative integers are what you can replace with arbitrary notes. The notes are named from 1 to m.
 

Output
For each test case, output the answer in one line.
 

Sample Input
2 5 3 83 86 77 15 93 35 86 92 49 3 3 3 1 2 10 5 36 11 68 67 29 82 30 62 23 67 35 29 2 22 58 69 67 93 56 11 42 29 73 21 19 -1 -1 5 -1 4 -1 -1 -1 4 -1
 

Sample Output
270 625
 

Source
 

有m个音节,并给你每两个连续音节的分数,给你一个音节数列,如果数列中的值为-1,表示这个位置可以填任何音节,求此音节数列的最大分数。
dp[i][j]表示在第i个音节上是音符j的最大分数,共有四种情况:(a,b),(?,b),(a,?),(?,?)。分情况计算就可以了。

//1660K	1057B
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[107][57],scor[57][57],a[107];
int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++)
            for(int j=1;j<=m;j++)
                scanf("%d",&scor[i][j]);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        memset(dp,0,sizeof(dp));
        for(int i=2;i<=n;i++)
        {
            if(a[i]>0)
            {
                if(a[i-1]>0)//(a,b)
                {
                    dp[i][a[i]]=dp[i-1][a[i-1]]+scor[a[i-1]][a[i]];
                }
                else//(?,b)
                {
                    for(int j=1;j<=m;j++)
                    {
                        dp[i][a[i]]=max(dp[i][a[i]],dp[i-1][j]+scor[j][a[i]]);
                    }
                }
            }
            else
            {
                for(int j=1;j<=m;j++)
                {
                    if(a[i-1]>0)//(a,?)
                    {
                        dp[i][j]=max(dp[i][j],dp[i-1][a[i-1]]+scor[a[i-1]][j]);
                    }
                    else//(?,?)
                    {
                        for(int k=1;k<=m;k++)
                        {
                            dp[i][j]=max(dp[i][j],dp[i-1][k]+scor[k][j]);
                        }
                    }
                }
            }
        }
        int ans=-1;
        for(int i=1;i<=m;i++)
            ans=max(ans,dp[n][i]);
        printf("%d\n",ans);
    }
    return 0;
}


HDU 5074 Hatsune Miku 暴力dp

原文:http://blog.csdn.net/crescent__moon/article/details/44654675

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!