首页 > 其他 > 详细

hdu 1158 Employment Planning

时间:2015-03-27 10:56:34      阅读:83      评论:0      收藏:0      [点我收藏+]

Employment Planning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3971    Accepted Submission(s): 1645


Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project. 
 

Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single ‘0‘.
 

Output
The output contains one line. The minimal total cost of the project.
 

Sample Input
3 4 5 6 10 9 11 0
 

Sample Output
199

简单dp,主要没有给出最大雇佣员工数目,当做200足够了。然后,找出当前月雇佣员工和上个月雇佣员工转化关系就好了。


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<queue>
#include<map>
using namespace std;
#define N 15
#define M 200
#define ll __int64
const int inf=0x7fffffff;
int a[N],mmax,n;
int dp[N][M];
void inti()       
{
    int i,j;
    for(i=0;i<=n;i++)
        for(j=0;j<=mmax;j++)
        dp[i][j]=inf;
}
int main()
{
    int i,j,k,add,sal,fire;
    while(scanf("%d",&n),n)
    {
        scanf("%d%d%d",&add,&sal,&fire);
        for(i=1,mmax=0;i<=n;i++)
        {
            scanf("%d",&a[i]);
            mmax=max(mmax,a[i]);
        }
        inti();
        for(i=a[1];i<=mmax;i++)
            dp[1][i]=(add+sal)*i;
        for(i=2;i<=n;i++)
        {
            for(j=a[i-1];j<=mmax;j++) //上个月合法雇人数目
            {
                for(k=a[i];k<=mmax;k++)  //这个月合法雇人数目
                {
                    if(k<j)
                        dp[i][k]=min(dp[i][k],dp[i-1][j]+(j-k)*fire+k*sal);
                    else
                        dp[i][k]=min(dp[i][k],dp[i-1][j]+(k-j)*add+k*sal);
                }
            }
        }
        int ans=inf;
        for(i=a[n];i<=mmax;i++)
            ans=min(ans,dp[n][i]);
        printf("%d\n",ans);
    }
    return 0;
}



hdu 1158 Employment Planning

原文:http://blog.csdn.net/u011721440/article/details/44672509

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!