首页 > 其他 > 详细

POJ2739——DFS——Sum of Consecutive Prime Numbers

时间:2015-03-27 21:22:05      阅读:97      评论:0      收藏:0      [点我收藏+]

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2
大意:连续素数共有多少种,用了DFS的思想,看来还是不会DFS OTZ去看了题解
技术分享
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int pri[2000] = {2};
int count = 0;
void prime()
{
   int temp = 1;
   int i,j;
   for( i = 3; i <= 10000;i++){
        for( j = 2; j <= i/2;j++)
            if(i%j == 0)
            break;
       if(j > i/2) pri[temp++] = i;
   }
}
int num(int n,int i)
{
    if(n-pri[i] == 0)
        count++;
    else if( n - pri[i] > 0)
       num(n-pri[i],i-1);
    return 0;
}
int main()
{
    int n,k;
    prime();

    while(~scanf("%d",&n)&&n){
            count = 0;
    for(int i = 0; i < 2000;i++){
        if(pri[i] == n) {
            count++;
            k = i -1;
            break;
        }
        else if( n < pri[i]){
            k = i -1;
           break;
        }
    }
    for(int i = k ; i >= 0;i--)
      num(n,i);
    printf("%d\n",count);
    }
    return 0;
}
View Code

 

 

POJ2739——DFS——Sum of Consecutive Prime Numbers

原文:http://www.cnblogs.com/zero-begin/p/4372634.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!