首页 > 其他 > 详细

hdoj 2051 Bitset

时间:2015-03-29 14:59:59      阅读:108      评论:0      收藏:0      [点我收藏+]

Bitset

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14685    Accepted Submission(s): 11173


Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

 

Input
For each case there is a postive number n on base ten, end of file.
 

 

Output
For each case output a number on base two.
 

 

Sample Input
1
2
3
 

 

Sample Output
1
10
11
 
十进制转化为二进制  太水了
 
#include<stdio.h>
#include<math.h>
int main()
{
	int n,j,sum;
	while(scanf("%d",&n)!=EOF)
	{
		sum=0;j=0;
		while(n!=0)
		{
			sum=sum+((n%2)*pow(10,j++));
			n=n/2;
		}
		printf("%d\n",sum);
	}
	return 0;
}

  

 

hdoj 2051 Bitset

原文:http://www.cnblogs.com/tonghao/p/4375642.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!