首页 > 其他 > 详细

杭电 HDU 1196 Lowest Bit

时间:2015-03-30 09:22:00      阅读:147      评论:0      收藏:0      [点我收藏+]

Lowest Bit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9052    Accepted Submission(s): 6656


Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
 

Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.
 

Output
For each A in the input, output a line containing only its lowest bit.
 

Sample Input
26 88 0
 

Sample Output
2 8
 

Author
SHI, Xiaohan
 水得要命啊
大晚上的 草
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
	int a;
	while(cin>>a,a)
	{int count=0;
        while(a%2==0)
		{count++;
			a/=2;
		}
		cout<<pow(2,count)<<endl;
	}
	return 0;
}

杭电 HDU 1196 Lowest Bit

原文:http://blog.csdn.net/lsgqjh/article/details/44736577

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!