首页 > 其他 > 详细

杭电 HDU 1266 Reverse Number

时间:2015-04-02 09:08:05      阅读:151      评论:0      收藏:0      [点我收藏+]

Reverse Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5763    Accepted Submission(s): 2643


Problem Description
Welcome to 2006‘4 computer college programming contest!

Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!

Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.
 

Input
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.
 

Output
For each test case, you should output its reverse number, one case per line.
 

Sample Input
3 12 -12 1200
 

Sample Output
21 -21 2100
 

Author
lcy
 

Source

HDU 2006-4 Programming Contest 

感觉用string做比较迅速方便啦…………~~~,这题就该一次提交ac之;

AC code:

#include<iostream>
#include<string>
using namespace std;
int main()
{
	int T,n;string str;
	while(cin>>T)
	{
		
		for(int i=0;i<T;i++)
		{
			cin>>str;
			int len=str.size();int k=len-1;
			if(str[0]!='-')
			{
				for(int i=len-1;i>=0;i--)
					if(str[i]!='0')
					{
						k=i;
						break;
					}
					for(int j=k;j>=0;j--)
						cout<<str[j];
					for(int p=0;p<len-1-k;p++)
						cout<<0;
					cout<<endl;
			}
			else
			{
				str.erase(0,1);
				cout<<'-';
			for(int i=len-1-1;i>=0;i--)
					if(str[i]!='0')
					{
						k=i;
						break;
					}
					for(int j=k;j>=0;j--)
						cout<<str[j];
					for(int p=0;p<len-2-k;p++)
						cout<<0;
					cout<<endl;
			}
		}
		
	}
return 0;
}
	


 

杭电 HDU 1266 Reverse Number

原文:http://blog.csdn.net/lsgqjh/article/details/44820443

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!