首页 > 其他 > 详细

UVA 562 (14.3.11)

时间:2014-03-12 01:28:18      阅读:440      评论:0      收藏:0      [点我收藏+]


  Dividing coins 

It‘s commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.


Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn‘t stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...


That‘s what this whole problem is about. Not everyone is capable of seeing instantly what‘s the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.


Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It‘s not allowed to split a single coin.

Input 

A line with the number of problems n, followed by n times:
  • a line with a non negative integer m (bubuko.com,布布扣) indicating the number of coins in the bag
  • a line with m numbers separated by one space, each number indicates the value of a coin.

Output 

The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

Sample Input 

2
3
2 3 5
4
1 2 4 6

Sample Output 

0
1


题意:按样例来说,有2组测试点,第一组有3个硬币,面额为2 3 5,第二组有4个硬币,面额为1 2 4 6,针对每一组硬币,分成两堆,两堆的总和差要最小。

思路:首先是要组合出所有可能面额,我第一次用了DP,大致是for(j = 0; j < sum; j++) DP[j + coin[i]] = 1; 结果WA了, 后来摸排了一下, 用第一组样例去推算, 发现会出现这样的情况, DP[2] = 1后, DP[4]也会等于1... 这就导致硬币被重复用了, 看了网上的代码, 要用从后往前推的方式...(我这里将不明白, 大家看代码, DP部分, 可以意会一下)


AC代码:

#include<stdio.h>
#include<string.h>

int main() {
    int coin[105];
    int DP[50005];
    int n;
    scanf("%d", &n);
    while(n--) {
        int m;
        int sum = 0;
        scanf("%d", &m);

        for(int i = 0; i < m; i++) {
            scanf("%d", &coin[i]);
            sum += coin[i];
        }

        memset(DP, 0, sizeof(DP));
        DP[0] = 1;

        for(int i = 0; i < m; i++) {
            for(int j = sum; j >= coin[i]; j--)
                if(DP[j-coin[i]])
                    DP[j] = 1;
        }

        for(int i = sum/2; i >= 0; i--) {
            if(DP[i]) {
                printf("%d\n", sum - 2*i);
                break;
            }
        }
    }
    return 0;
}

UVA 562 (14.3.11),布布扣,bubuko.com

UVA 562 (14.3.11)

原文:http://blog.csdn.net/qq297060023/article/details/21024327

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!