首页 > 其他 > 详细

杭电 HDU ACM 1391 Number Steps

时间:2015-04-05 09:13:10      阅读:123      评论:0      收藏:0      [点我收藏+]

Number Steps

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4376    Accepted Submission(s): 2656


Problem Description
Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.

技术分享


You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.
 

Input
The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.
 

Output
For each point in the input, write the number written at that point or write No Number if there is none.
 

Sample Input
3 4 2 6 6 3 4
 

Sample Output
6 12 No Number
 

Source
找规律即可,两条线 ,就是两个方程一个是y=x;一个是y=x-2;如果两点坐标不在这两条直线任何一条,就no number ,否则肯定有值。
 
 
#include<iostream>
using namespace std;
int main()
{
	int n;
	cin>>n;int x,y;
	while(n--)
	{
		
		cin>>x>>y;
		if((x!=y)&&(y!=x-2))
			cout<<"No Number"<<endl;
		else
		{
			if(x==y)
			{
				if(x&1)
					cout<<2*x-1<<endl;
				else
					cout<<2*x<<endl;
			}
			else 
			{
				if(x&1)
					cout<<2*(x-1)-1<<endl;
				else
					cout<<2*(x-1)<<endl;
			}
		}
	}
	return 0;
}


 

杭电 HDU ACM 1391 Number Steps

原文:http://blog.csdn.net/lsgqjh/article/details/44874433

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!