首页 > 其他 > 详细

杭电 HDU ACM 1491 Octorber 21st

时间:2015-04-06 12:51:32      阅读:148      评论:0      收藏:0      [点我收藏+]

Octorber 21st

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3430    Accepted Submission(s): 2108


Problem Description
HDU‘s 50th birthday, on Octorber 21st, is coming. What an exciting day!! As a student of HDU, I always want to know how many days are there between today and Octorber 21st.So, write a problem and tell me the answer.Of course, the date I give you is always in 2006.

技术分享

 

Input
The input consists of T test cases. The number of T is given on the first line of the input file.Following T lines, which represent dates, one date per line. The format for a date is "month day" where month is a number between 1 (which indicates January) and 12 (which indicates December), day is a number between 1 and 31.All the date in the input are in 2006, you can assume that all the dates in the input are legal(合法).
 

Output
For each case, if the date is before Octorber 21st, you should print a number that between the date and Octorber 21st.If the day is beyond Octorber 21st, just print "What a pity, it has passed!".If the date is just Octorber 21st, print"It‘s today!!".
 

Sample Input
7 10 20 10 19 10 1 10 21 9 1 11 11 12 12
 

Sample Output
1 2 20 It‘s today!! 50 What a pity, it has passed! What a pity, it has passed!
 

Author
8600
 

Source
 
唉 按部就班的写 就ok
#include<iostream>
using namespace std;
int main()
{
	int n,a,b;
	cin>>n;
	while(n--)
	{
		cin>>a>>b;int sum=0;
		if(a==10&&b>21)
			cout<<"What a pity, it has passed!"<<endl;
		else if(a==10&&b==21)
			cout<<"It's today!!"<<endl;
		else if(a>10)
			cout<<"What a pity, it has passed!"<<endl;
	
		else if(a==10&&b<21)
		cout<<21-b<<endl;
		else
		{
			for(int i=a;i<10;i++)
			{
				if(i==a)
				{
					if(a==2)
						sum+=28-b;

					
				  else if(i==3||i==1||i==5||i==7||i==8)
				
					sum+=31-b;
				  else 
					  sum+=30-b;
				}
				else if(i==3||i==1||i==5||i==7||i==8)
					sum+=31;
				else if(i==2)
					sum+=28;
				else
					sum+=30;
			//	cout<<"sum="<<"a="<<i<<" "<<sum<<endl;
			}
			
			sum=sum+21;
		cout<<sum<<endl;
		}
	}
	return 0;
}

			

杭电 HDU ACM 1491 Octorber 21st

原文:http://blog.csdn.net/lsgqjh/article/details/44901039

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!