首页 > 其他 > 详细

杭电 HDU ACM 1562 Guess the number

时间:2015-04-06 15:48:12      阅读:300      评论:0      收藏:0      [点我收藏+]

Guess the number

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3035    Accepted Submission(s): 2281


Problem Description
Happy new year to everybody!
Now, I want you to guess a minimum  number x betwwn 1000 and 9999 to let
(1) x % a = 0;
(2) (x+1) % b = 0;
(3) (x+2) % c = 0;
and a, b, c are integers between 1 and 100.
Given a,b,c, tell me what is the number of x ?
 

Input
The number of test cases c is in the first line of input, then c test cases followed.every test contains three integers a, b, c.
 

Output
For each test case your program should output one line with the minimal number x, you should remember that x is between 1000 and 9999. If there is no answer for x, output "Impossible".
 

Sample Input
2 44 38 49 25 56 3
 

Sample Output
Impossible 2575
 

Author
8600
 

Source
 
做这题目简直浪费时间
#include<iostream>
using namespace std;
int main()
{
	int n,a,b,c,i;
	cin>>n;
	while(n--)
	{
		cin>>a>>b>>c;
		for(i=1000;i<=9999;i++)
			if((i%a==0)&&((i+1)%b==0)&&((i+2)%c==0))
			{
				cout<<i<<endl;;
				break;
			}
		if(i>9999)
			cout<<"Impossible"<<endl;
	}
	return 0;
}


杭电 HDU ACM 1562 Guess the number

原文:http://blog.csdn.net/lsgqjh/article/details/44901559

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!