首页 > 其他 > 详细

ssu 499 Greatest Greatest Common Divisor

时间:2014-03-12 16:32:26      阅读:515      评论:0      收藏:0      [点我收藏+]

499. Greatest Greatest Common Divisor

Time limit per test: 0.5 second(s)
Memory limit: 262144 kilobytes
input: standard
output: standard

Andrew has just made a breakthrough in sociology: he realized how to predict whether two persons will be good friends or not. It turns out that each person has an inner friendship number (a positive integer). And the quality of friendship between two persons is equal to the greatest common divisor of their friendship number. That means there are prime people (with a prime friendship number) who just can‘t find a good friend, andbubuko.com,布布扣Wait, this is irrelevant to this problem. You are given a list of friendship numbers for several people. Find the highest possible quality of friendship among all pairs of given people.
Input
The first line of the input file contains an integer n (bubuko.com,布布扣) — the number of people to process. The next n lines contain one integer each, between 1 and bubuko.com,布布扣 (inclusive), the friendship numbers of the given people. All given friendship numbers are distinct.
Output
Output one integer — the highest possible quality of friendship. In other words, output the greatest greatest common divisor among all pairs of given friendship numbers.
Example(s)
sample input
sample output
4
9
15
25
16
5
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <map>
#include <cmath>
#include <queue>
#include <cstring>
#include <set>
#include <stack>
#include <string>
#define LL long long
#define maxn 100010
#define mod 1000000007
#define INF 2000000
#define MAX 16000010
#define eps 1e-6
using namespace std;

bool vi[maxn*10] ;
int Max ;
int max(int a ,int b){ return a > b ? a : b ;}

void insert( int n )
{
    int m ,i ,k ;
    m = sqrt(n+0.5) ;
    for( i = 1 ; i <= m ;i++)if(n%i == 0)
    {
        k = n/i ;
        if(vi[i])
        {
            Max = max(Max,i) ;
        }
        else vi[i] = true ;
        if(vi[k]&&k != i)
        {
            Max = max(Max,k) ;
        }
        else vi[k] = true ;
    }
}
int main()
{
    int i ,m , tt , j , n ;
    int L , R , mid ;
    // freopen("in.txt","r",stdin) ;
   // 枚举每个数的因子是可以过的  
    while( scanf("%d",&n) != EOF)
    {
        memset(vi,0,sizeof(vi)) ;
         Max = 0 ;
         for( i = 1 ; i <= n ;i++ ){
             scanf("%d",&m) ;
             insert(m) ;
         }
        printf("%d\n",Max) ;
    }
    return 0 ;
}

 

ssu 499 Greatest Greatest Common Divisor,布布扣,bubuko.com

ssu 499 Greatest Greatest Common Divisor

原文:http://www.cnblogs.com/20120125llcai/p/3596475.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!